summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/gcc.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm46
1 files changed, 20 insertions, 26 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a825b6661e..f526680f56 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -171,16 +171,12 @@ where the OS part is overloaded to denote a specific ABI---into GCC
"lib" ;libgcc_s, libgomp, etc. (15+ MiB)
"debug")) ;debug symbols of run-time libraries
- (inputs `(("gmp" ,gmp)
- ("mpfr" ,mpfr)
- ("mpc" ,mpc)
- ("libelf" ,libelf)
- ("zlib" ,zlib)))
+ (inputs (list gmp mpfr mpc libelf zlib))
;; GCC < 5 is one of the few packages that doesn't ship .info files.
;; Newer texinfos fail to build the manual, so we use an older one.
- (native-inputs `(("perl" ,perl) ;for manpages
- ("texinfo" ,texinfo-5)))
+ (native-inputs (list perl ;for manpages
+ texinfo-5))
(arguments
`(#:out-of-source? #t
@@ -398,9 +394,8 @@ Go. It also includes runtime support libraries for these languages.")
"pa" "sh" "tilepro" "xtensa")))))
(supported-systems %supported-systems)
(inputs
- `(("isl" ,isl-0.11)
- ("cloog" ,cloog)
- ,@(package-inputs gcc-4.7)))))
+ (modify-inputs (package-inputs gcc-4.7)
+ (prepend isl-0.11 cloog)))))
(define-public gcc-4.9
(package (inherit gcc-4.8)
@@ -431,8 +426,8 @@ Go. It also includes runtime support libraries for these languages.")
'("aarch64" "alpha" "bfin" "i386" "m68k" "nios2"
"pa" "sh" "tilepro" "xtensa")))))
;; Override inherited texinfo-5 with latest version.
- (native-inputs `(("perl" ,perl) ;for manpages
- ("texinfo" ,texinfo)))
+ (native-inputs (list perl ;for manpages
+ texinfo))
(arguments
(if (%current-target-system)
(package-arguments gcc-4.8)
@@ -496,9 +491,9 @@ Go. It also includes runtime support libraries for these languages.")
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
(inputs
- `(;; GCC5 needs <isl/band.h> which is removed in later versions.
- ("isl" ,isl-0.18)
- ,@(package-inputs gcc-4.7)))))
+ (modify-inputs (package-inputs gcc-4.7)
+ (prepend ;; GCC5 needs <isl/band.h> which is removed in later versions.
+ isl-0.18)))))
(define-public gcc-6
(package
@@ -992,13 +987,13 @@ provides the GNU compiler for the Go programming language."))
(version (package-version gcc))
(synopsis "GNU libstdc++ documentation")
(outputs '("out"))
- (native-inputs `(("doxygen" ,doxygen)
- ("texinfo" ,texinfo)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("graphviz" ,graphviz))) ;for 'dot', invoked by 'doxygen'
+ (native-inputs (list doxygen
+ texinfo
+ libxml2
+ libxslt
+ docbook-xml
+ docbook-xsl
+ graphviz)) ;for 'dot', invoked by 'doxygen'
(inputs '())
(propagated-inputs '())
(arguments
@@ -1074,7 +1069,7 @@ provides the GNU compiler for the Go programming language."))
(substitute* (string-append out "/lib/libisl.la")
(("^old_library=.*")
"old_library=''\n"))))))))
- (inputs `(("gmp" ,gmp)))
+ (inputs (list gmp))
(home-page "http://isl.gforge.inria.fr/")
(synopsis
"Manipulating sets and relations of integer points \
@@ -1140,8 +1135,7 @@ dependence analysis and bounds on piecewise step-polynomials.")
"0a12rwfwp22zd0nlld0xyql11cj390rrq1prw35yjsw8wzfshjhw"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
- (inputs `(("gmp" ,gmp)
- ("isl" ,isl-0.11)))
+ (inputs (list gmp isl-0.11))
(arguments '(#:configure-flags '("--with-isl=system")))
(home-page "http://www.cloog.org/")
(synopsis "Library to generate code for scanning Z-polyhedra")
@@ -1171,7 +1165,7 @@ effective code.")
(base32
"1sfsj9256w18qzylgag2h5h377aq8in8929svblfnj9svfriqcys"))))
(build-system gnu-build-system)
- (native-inputs `(("texinfo" ,texinfo)))
+ (native-inputs (list texinfo))
(arguments
'(#:phases (modify-phases %standard-phases
(delete 'configure)