summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-12 17:02:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-12 17:05:10 +0300
commit76fc36d0a7215979bb74c05840f5a4de4ab5ea93 (patch)
tree1cb84a53c060fc33095fcc7eee9ef02c2f6f0f46 /gnu/packages/gcc.scm
parenta55f64917dc9a56d5a95de625bc3092b625df0ed (diff)
downloadguix-patches-76fc36d0a7215979bb74c05840f5a4de4ab5ea93.tar
guix-patches-76fc36d0a7215979bb74c05840f5a4de4ab5ea93.tar.gz
gnu: gcc: Update gcc to 8.
* gnu/packages/gcc.scm (gcc): Define as gcc-8. * gnu/packages/commencement.scm (gcc-toolchain-7): Use make-gcc-toolchain procedure. (gcc-toolchain-8): Define as gcc-toolchain. * gnu/packages/game-development (python2-renpy)[native-inputs], * gnu/packages/gnome.scm (gnome-commander)[native-inputs], * gnu/packages/wm.scm (waybar)[native-inputs]: Remove gcc-8.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 13d6b20801..e9f5889570 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -585,7 +585,7 @@ It also includes runtime support libraries for these languages.")))
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions and the gfortran definition
;; accordingly.
-(define-public gcc gcc-7)
+(define-public gcc gcc-8)
(define-public (make-libstdc++ gcc)
"Return a libstdc++ package based on GCC. The primary use case is when