summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
committerLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
commit74288230ea8b2310495dc2739f39ceadcc143fd0 (patch)
tree73ba6c7c13d59c5f92b409c94dccfff159e08f4d /gnu/packages/gcc.scm
parent92e779592d269ca1924f184496eb4ca832997b12 (diff)
parentaa21c764d65068783ae31febee2a92eb3d138a24 (diff)
downloadguix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar
guix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm35
1 files changed, 30 insertions, 5 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 8381392ba4..206c67ed99 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -380,14 +380,14 @@ Go. It also includes runtime support libraries for these languages.")
(define-public gcc-6
(package
(inherit gcc-5)
- (version "6.2.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.bz2"))
(sha256
(base32
- "1idpf43988v1a6i8lw9ak1r7igcfg1bm5kn011iydlr2qygmhi4r"))
+ "17xjz30jb65hcf714vn9gcxvrrji8j20xm7n33qg1ywhyzryfsph"))
(patches (search-patches "gcc-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
@@ -510,8 +510,11 @@ as the 'native-search-paths' field."
%generic-search-paths))
(define-public gfortran
- (custom-gcc gcc "gfortran" '("fortran")
- %generic-search-paths))
+ ;; Note: Update this when GCC changes! We cannot use
+ ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
+ ;; that is not 'eq?' with GFORTRAN-4.9, and thus 'fold-packages' would
+ ;; report two gfortran@4.9 that are in fact identical.
+ gfortran-4.9)
(define-public gfortran-5
(custom-gcc gcc-5 "gfortran" '("fortran")
@@ -537,6 +540,7 @@ as the 'native-search-paths' field."
(define-public gcj
(package (inherit gcc)
(name "gcj")
+ (version (package-version gcc))
(inputs
`(("fastjar" ,fastjar)
("perl" ,perl)
@@ -545,6 +549,15 @@ as the 'native-search-paths' field."
,@(package-inputs gcc)))
(native-inputs
`(("dejagnu" ,dejagnu)
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ `(("arm-patch" ,(origin
+ (method url-fetch)
+ (uri (search-patch "gcj-arm-mode.patch"))
+ (sha256
+ (base32
+ "1z15xs5yx6qinnb572swzxrn9f668sw7ga5280q3gznj1jyrynfn")))))
+ '())
,@(package-native-inputs gcc)))
(native-search-paths %generic-search-paths)
@@ -572,6 +585,14 @@ as the 'native-search-paths' field."
,flags))))
((#:phases phases)
`(modify-phases ,phases
+ ;; Conditionally add phase to apply patch
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ `((add-after 'unpack 'apply-arm-patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "patch" "-p1"
+ "-i" (assoc-ref inputs "arm-patch"))))))
+ '())
(add-after
'unpack 'add-lib-output-to-rpath
(lambda _
@@ -584,6 +605,10 @@ as the 'native-search-paths' field."
'unpack 'patch-testsuite
;; dejagnu-1.6 removes the 'absolute' command
(lambda _
+ ;; This test fails on armhf. It seems harmless enough to disable it.
+ (for-each delete-file '("libjava/testsuite/libjava.lang/Throw_2.java"
+ "libjava/testsuite/libjava.lang/Throw_2.out"
+ "libjava/testsuite/libjava.lang/Throw_2.jar"))
(substitute* "libjava/testsuite/lib/libjava.exp"
(("absolute") "file normalize"))
#t))