summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 01:48:45 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:01:46 -0400
commit61a815ebeba6168594dd08b2e77b9b86d4477c60 (patch)
tree563e658d897b90d77893525ca68fbb30f4ce080f /gnu/packages/gcc.scm
parent67eb6f508edd26e0acc475eb25d6ae1eb164880a (diff)
downloadguix-patches-61a815ebeba6168594dd08b2e77b9b86d4477c60.tar
guix-patches-61a815ebeba6168594dd08b2e77b9b86d4477c60.tar.gz
gnu: libstdc++-doc: Use invoke.
* gnu/packages/gcc.scm (make-libstdc++-doc)[arguments]: Use invoke.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 27f4b04d9a..3fc95fa429 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -769,7 +769,8 @@ as the 'native-search-paths' field."
#:phases (modify-phases %standard-phases
(add-before 'configure 'chdir
(lambda _
- (chdir "libstdc++-v3")))
+ (chdir "libstdc++-v3")
+ #t))
(add-before 'configure 'set-xsl-directory
(lambda* (#:key inputs #:allow-other-keys)
(let ((docbook (assoc-ref inputs "docbook-xsl")))
@@ -778,22 +779,23 @@ as the 'native-search-paths' field."
(("@XSL_STYLE_DIR@")
(string-append
docbook "/xml/xsl/"
- (strip-store-file-name docbook)))))))
+ (strip-store-file-name docbook))))
+ #t)))
(replace 'build
(lambda _
;; XXX: There's also a 'doc-info' target, but it
;; relies on docbook2X, which itself relies on
;; DocBook 4.1.2, which is not really usable
;; (lacks a catalog.xml.)
- (zero? (system* "make"
- "doc-html"
- "doc-man"))))
+ (invoke "make"
+ "doc-html"
+ "doc-man")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "make"
- "doc-install-html"
- "doc-install-man"))))))))))
+ (invoke "make"
+ "doc-install-html"
+ "doc-install-man")))))))))
(define-public libstdc++-doc-4.9
(make-libstdc++-doc gcc-4.9))