summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-06-13 14:01:25 -0700
committerLudovic Courtès <ludo@gnu.org>2021-07-05 13:12:03 +0200
commit5318bade32e2a3a801e838286439074aeaf1e3c7 (patch)
tree803fac9d3170051de4b105de3474bf6f5a3f6a84 /gnu/packages/gcc.scm
parenta159586f8ae4db8a0fcf608b411f962817c3db60 (diff)
downloadguix-patches-5318bade32e2a3a801e838286439074aeaf1e3c7.tar
guix-patches-5318bade32e2a3a801e838286439074aeaf1e3c7.tar.gz
gnu: custom-gcc: Update regex for removing executables.
Do not match "gccgo". Match "gcov-dump" and "gcov-tool", as well as "lto-dump" (which was introduced in GCC 10). * gnu/packages/gcc.scm (custom-gcc)[arguments]: Update regex used for matching broken or conflicting executables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c7fcb22693..ba691010bb 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -722,9 +722,10 @@ as the 'native-search-paths' field."
`(modify-phases ,phases
(add-after 'install 'remove-broken-or-conflicting-files
(lambda* (#:key outputs #:allow-other-keys)
- (for-each delete-file
- (find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))))))))))
+ (for-each
+ delete-file
+ (find-files (string-append (assoc-ref outputs "out") "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are