summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-10 17:00:27 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-12 14:09:28 +0200
commit25bd72678ae4048b0b84ee82bc5f2644367e9715 (patch)
tree00faba0f9f6f0f7c2ea307703739117d1fd350a0 /gnu/packages/gcc.scm
parenta3baaaa07a77ae03e891ed5b462d0836d8a2a66e (diff)
downloadguix-patches-25bd72678ae4048b0b84ee82bc5f2644367e9715.tar
guix-patches-25bd72678ae4048b0b84ee82bc5f2644367e9715.tar.gz
gnu: gcc@5: Build with isl@0.18.
* gnu/packages/gcc.scm (gcc-5)[inputs]: Change ISL to ISL-0.18. (isl-0.18): New public variable.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5bdd70b0db..46b70ce497 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -451,7 +451,8 @@ Go. It also includes runtime support libraries for these languages.")
"$OBJDUMP_FOR_TARGET -T"))
#t))))
(inputs
- `(("isl" ,isl)
+ `(;; GCC5 needs <isl/band.h> which is removed in later versions.
+ ("isl" ,isl-0.18)
,@(package-inputs gcc-4.7)))))
(define-public gcc-6
@@ -860,6 +861,20 @@ reduction, transitive closures on maps (which may encode infinite graphs),
dependence analysis and bounds on piecewise step-polynomials.")
(license lgpl2.1+)))
+(define-public isl-0.18
+ (package
+ (inherit isl)
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "http://isl.gforge.inria.fr/isl-"
+ version ".tar.bz2")
+ (string-append %gcc-infrastructure
+ "isl-" version ".tar.gz")))
+ (sha256
+ (base32
+ "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))))
+
(define-public isl-0.11
(package
(inherit isl)