summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-12 10:58:44 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-24 23:31:34 +0100
commit25bc0f34c6c059394f546f29a203c2cb9b7cdcf6 (patch)
tree09e5feae38f497d06c382391cbc6975b7b5e40a3 /gnu/packages/gcc.scm
parenteef44fea17a735d2f4048a747d16af478d4b9dbc (diff)
downloadguix-patches-25bc0f34c6c059394f546f29a203c2cb9b7cdcf6.tar
guix-patches-25bc0f34c6c059394f546f29a203c2cb9b7cdcf6.tar.gz
gnu: bootstrap: gcc-static: Use gcc-5.
* gnu/packages/make-bootstrap.scm (gcc-static): Use gcc-5. This fixes building libstdc++-boot0 with a newly built %bootstrap-gcc. (%gcc-stripped): Likewise. (gcc-for-bootstrap): Likewise. * gnu/packages/patches/gcc-5-hurd.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-5): Use it.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5c5c51a0ad..6221a123d8 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -471,7 +471,8 @@ Go. It also includes runtime support libraries for these languages.")
"gcc-5-source-date-epoch-1.patch"
"gcc-5-source-date-epoch-2.patch"
"gcc-6-libsanitizer-mode-size.patch"
- "gcc-fix-texi2pod.patch"))
+ "gcc-fix-texi2pod.patch"
+ "gcc-5-hurd.patch"))
(modules '((guix build utils)))
(snippet
;; Fix 'libcc1/configure' error when cross-compiling GCC.