summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-27 17:08:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-27 17:10:22 +0300
commit007ec66206fdda28b15f0f638adbdc979d94a6e2 (patch)
tree2d19d5105dba2976d79f1b5bbd774257d92e90d8 /gnu/packages/gcc.scm
parente97376c15f386f87cbedc7e9edd7479e65aa90ba (diff)
downloadguix-patches-007ec66206fdda28b15f0f638adbdc979d94a6e2.tar
guix-patches-007ec66206fdda28b15f0f638adbdc979d94a6e2.tar.gz
gnu: Add gcc-toolchain-11.
* gnu/packages/gcc.scm (gcc-11): New variable. * gnu/packages/commencement.scm (gcc-toolchain-11): New variable.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a412c93c29..a444abf943 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -594,6 +594,20 @@ It also includes runtime support libraries for these languages.")))
(patches (search-patches "gcc-9-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
+(define-public gcc-11
+ (package
+ (inherit gcc-8)
+ (version "11.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1pwxrjhsymv90xzh0x42cxfnmhjinf2lnrrf3hj5jq1rm2w6yjjc"))
+ (patches (search-patches "gcc-9-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions.
(define-public gcc gcc-7)