summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-19 23:45:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:20 -0500
commitdaf54a3953e807d46c4c21bbc709879c6e8d31e8 (patch)
tree8bd2d2e68a593f010bb962f7d816098cb5de238c /gnu/packages/gawk.scm
parent000291fd4325d2afd1f9f93125986275f6e7ab7a (diff)
downloadguix-patches-daf54a3953e807d46c4c21bbc709879c6e8d31e8.tar
guix-patches-daf54a3953e807d46c4c21bbc709879c6e8d31e8.tar.gz
gnu: gawk: Use regular bash to cope with test suite failures.
Fixes <https://issues.guix.gnu.org/51286>. * gnu/packages/gawk.scm (gawk): Remove trailing #t. [inputs]: Always use bash.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6dab274be1..f8f13fc9a3 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -55,9 +55,7 @@
'((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '())
-
- #t)))
+ '()))))
(add-before 'check 'adjust-test-infrastructure
(lambda _
@@ -80,14 +78,12 @@
;; against the actual test output.
(substitute* "test/watchpoint1.ok"
(("#! /usr/bin/gawk")
- (string-append "#!" (which "gawk"))))
- #t)))))
+ (string-append "#!" (which "gawk")))))))))
(inputs `(("libsigsegv" ,libsigsegv)
-
- ,@(if (%current-target-system)
- `(("bash" ,bash))
- '())))
+ ;; Use the full-fledged Bash package, otherwise the test suite
+ ;; sometimes fail non-deterministically.
+ ("bash" ,bash)))
(home-page "https://www.gnu.org/software/gawk/")
(synopsis "Text scanning and processing language")