summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-22 16:29:19 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-22 16:29:19 +0200
commitd16368cf41f1b685c523de04f86ded11914c218b (patch)
tree5b1ba0d31e93cae91c302f024c9d71d7afa4b5dd /gnu/packages/gawk.scm
parent2a511f7a1a114eeba49273a1c32d80dfff5dee10 (diff)
downloadguix-patches-d16368cf41f1b685c523de04f86ded11914c218b.tar
guix-patches-d16368cf41f1b685c523de04f86ded11914c218b.tar.gz
gnu: gawk: Upgrade to 4.1.0.
* gnu/packages/gawk.scm (gawk): Update to 4.1.0. Remove wrong-headed comments.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 1b19f7bfd2..da570e6617 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -27,13 +27,13 @@
(define-public gawk
(package
(name "gawk")
- (version "4.0.2")
+ (version "4.1.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
- (base32 "04vd0axif762mf781pj3days6ilv2333b9zi9c50y5mma66g5q91"))))
+ (base32 "0hin2hswbbd6kd6i4zzvgciwpl5fba8d2s524z8y5qagyz3x010q"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
@@ -45,7 +45,6 @@
'configure 'set-shell-file-name
(lambda* (#:key inputs #:allow-other-keys)
;; Refer to the right shell.
- ;; FIXME: Remove `else' arm upon core-updates.
(let ((bash (assoc-ref inputs "bash")))
(substitute* "io.c"
(("/bin/sh")
@@ -53,7 +52,6 @@
%standard-phases)))
(inputs `(("libsigsegv" ,libsigsegv)
- ;; TODO: On next core-updates, make Bash input unconditional.
,@(if (%current-target-system)
`(("bash" ,bash))
'())))