summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-21 22:39:18 -0400
committerMark H Weaver <mhw@netris.org>2014-08-23 20:48:21 -0400
commitc198872b99cdb1e483ecb91cce4026bc9e35ac8a (patch)
tree056511e27b3094db286ec77a9b7759d043493bfd /gnu/packages/gawk.scm
parent8a0576f175a656a332c5a4ca65168e76c56af5c3 (diff)
downloadguix-patches-c198872b99cdb1e483ecb91cce4026bc9e35ac8a.tar
guix-patches-c198872b99cdb1e483ecb91cce4026bc9e35ac8a.tar.gz
gnu: Rely on 'file' implicit input and 'patch-usr-bin-file'.
* gnu/packages/admin.scm (sudo): * gnu/packages/gawk.scm (gawk): Remove workaround on MIPS. * gnu/packages/mcrypt.scm (mcrypt, libmhash): * gnu/packages/file.scm (file): Remove 'file' from native-inputs. * gnu/packages/mc.scm (mc): * gnu/packages/pretty-print.scm (a2ps, trueprint, source-highlight): * gnu/packages/image.scm (libtiff): Remove 'file' from native-inputs. Remove 'patch-configure' phase.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6185409fb7..fd14b4c83e 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -55,17 +55,6 @@
'((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '())
-
- ;; XXX FIXME gawk 4.1.1 was bootstrapped with a prerelease
- ;; libtool, which fails on MIPS in the absence of
- ;; /usr/bin/file. As a temporary workaround, we patch
- ;; the configure script to hardcode use of the little
- ;; endian N32 ABI on MIPS.
- ,@(if (equal? "mips64el-linux" (or (%current-target-system)
- (%current-system)))
- '((substitute* "extension/configure"
- (("\\$emul") "elf32ltsmipn32")))
'())))
%standard-phases)))
(inputs `(("libsigsegv" ,libsigsegv)