summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 12:13:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-04 00:09:29 +0200
commitb6ac54517cc878034f57f983cfe561ebf8e2eb7f (patch)
treecb9df45ab58f2aaf7ccce6613a20fb7995c27178 /gnu/packages/gawk.scm
parentf2d7bbb537dd3e3fa3b0215549640d2d9c0aeaec (diff)
downloadguix-patches-b6ac54517cc878034f57f983cfe561ebf8e2eb7f.tar
guix-patches-b6ac54517cc878034f57f983cfe561ebf8e2eb7f.tar.gz
gnu: commencement: Remove the tricky locale compatibility handling.
This is made unnecessary by the use of 'GUIX_LOCPATH'. * gnu/packages/commencement.scm (locale-proof-package): Remove. (%boot5-inputs): Add on GLIBC-UTF8-LOCALES-FINAL. This reverts parts of commit 28cbc58. * gnu/packages/gawk.scm (gawk): Set 'GUIX_LOCPATH' instead of 'LOCPATH'.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index d2639a32a3..fa07f5bd4b 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -63,7 +63,7 @@
;; A bunch of tests require the availability of a UTF-8
;; locale and otherwise fail. Since UTF-8 locales are not
;; available during bootstrap, create one here.
- (setenv "LOCPATH" (getcwd))
+ (setenv "GUIX_LOCPATH" (getcwd))
(zero? (system* "localedef" "--no-archive"
"--prefix" (getcwd) "-i" "en_US"
"-f" "UTF-8" "./en_US.UTF-8")))