summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:49:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commit7184b4b1bd839cd4fd0c9630c050c7854174057d (patch)
tree4d0a639e98498bda398557ab53a674caaf332902 /gnu/packages/gawk.scm
parentda6dd842d038aa0761918305953ad92951fb663f (diff)
downloadguix-patches-7184b4b1bd839cd4fd0c9630c050c7854174057d.tar
guix-patches-7184b4b1bd839cd4fd0c9630c050c7854174057d.tar.gz
gnu: Remove now unneeded 'localedef' invocations.
This is a followup to commit b0fd2bd. * gnu/packages/gawk.scm (gawk)[arguments] <install-locales>: Add comment on why we leave this here. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'install-locales' phase. * gnu/packages/swig.scm (swig)[arguments]: Likewise. * gnu/packages/python.scm (python-matplotlib): Remove 'LOCPATH' setting and 'localedef' invocation. (python-scipy): Likewise.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index e0d3f41ac2..06ecf6a064 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -61,7 +61,8 @@
'check 'install-locales
(lambda _
;; A bunch of tests require the availability of a UTF-8
- ;; locale and otherwise fail. Give them what they want.
+ ;; locale and otherwise fail. Since UTF-8 locales are not
+ ;; available during bootstrap, create one here.
(setenv "LOCPATH" (getcwd))
(zero? (system* "localedef" "--no-archive"
"--prefix" (getcwd) "-i" "en_US"