summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-08 18:24:32 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:43:31 +0200
commit4e47b77533878bc8ded887bbe9c4ea7a3e0b03c0 (patch)
treec7c332de776e0d53cb5dfc99177dc90887252347 /gnu/packages/gawk.scm
parent84943cc9f2d06f7876ffc2bc4ebc0f28a9af9815 (diff)
downloadguix-patches-4e47b77533878bc8ded887bbe9c4ea7a3e0b03c0.tar
guix-patches-4e47b77533878bc8ded887bbe9c4ea7a3e0b03c0.tar.gz
gnu: bash: Update to 5.1.8.
* gnu/packages/bash.scm (patch-url): Adjust for 5.1. (%patch-series-5.0): Rename to ... (%patch-series-5.1): Add the 5.1 patches. (bash): Update to 5.1 and and adjust for renamed variable. * gnu/packages/gawk.scm (gawk)[arguments]: Adjust test that fails with the new Bash.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6b5eaa1f4c..6dab274be1 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -66,6 +66,16 @@
(substitute* "test/Makefile"
(("\\| more") ""))
+ ;; Silence a warning from bash about not being able
+ ;; to change to an ISO-8859-1 locale. The test itself
+ ;; works fine, but newer versions of bash give a
+ ;; locale warning which mangles the test output.
+ (substitute* "test/localenl.sh"
+ (("for LC_ALL in")
+ "for LC in")
+ (("export LC_ALL\n")
+ "export LC_ALL=$LC 2>/dev/null\n"))
+
;; Adjust the shebang in that file since it is then diff'd
;; against the actual test output.
(substitute* "test/watchpoint1.ok"