summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-25 00:00:09 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-25 00:00:09 +0200
commit1e4310f1f269d26f7129e1bae167c8d8b096ea10 (patch)
treefdf97301ea9904149a3c18ec758e4c7d90fe61fe /gnu/packages/gawk.scm
parentf7c3429073fb0d32ccd124b7a35828c5e2d52b65 (diff)
downloadguix-patches-1e4310f1f269d26f7129e1bae167c8d8b096ea10.tar
guix-patches-1e4310f1f269d26f7129e1bae167c8d8b096ea10.tar.gz
gnu: gawk: Allow cross-compilation.
* gnu/packages/gawk.scm (gawk)[arguments]: Annihilate the `check-for-shared-lib-support' target when cross-compiling.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index da570e6617..aff856d9f3 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -38,9 +38,6 @@
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
- ;; Work around test failure on Cygwin.
- #:tests? ,(not (string=? (%current-system) "i686-cygwin"))
-
#:phases (alist-cons-before
'configure 'set-shell-file-name
(lambda* (#:key inputs #:allow-other-keys)
@@ -48,7 +45,16 @@
(let ((bash (assoc-ref inputs "bash")))
(substitute* "io.c"
(("/bin/sh")
- (string-append bash "/bin/bash")))))
+ (string-append bash "/bin/bash")))
+
+ ;; When cross-compiling, remove dependencies on the
+ ;; `check-for-shared-lib-support' target, which tries to
+ ;; run the cross-built `gawk'.
+ ,@(if (%current-target-system)
+ '((substitute* "extension/Makefile.in"
+ (("^.*: check-for-shared-lib-support" match)
+ (string-append "### " match))))
+ '())))
%standard-phases)))
(inputs `(("libsigsegv" ,libsigsegv)