summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-10 23:00:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-10 23:00:42 +0200
commit173c6ec8a391dee9d7b38a20370e48a4a05288d0 (patch)
tree9e1a6d2d22abc284e8d795d252f0fa52745e349b /gnu/packages/gawk.scm
parent1b8217019222ff07176e9846464897de54bcf753 (diff)
downloadguix-patches-173c6ec8a391dee9d7b38a20370e48a4a05288d0.tar
guix-patches-173c6ec8a391dee9d7b38a20370e48a4a05288d0.tar.gz
Revert "gnu: gawk: Update to 4.2.0."
This reverts commit 78cd051eef9e25a6993478619d2bdb2db60565a6. This commit was added past the merge window and caused conflicts with gettext's test suite.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 7828a4cd0e..e318993ace 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -1,7 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,13 +29,13 @@
(define-public gawk
(package
(name "gawk")
- (version "4.2.0")
+ (version "4.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
- (base32 "1wm9lqj77y7xz07zi0n187aqm8zavzxzpm1j53ahxz81q0qwvwyl"))))
+ (base32 "0rn2mmjxm767zliqzd67j7h2ncjn4j0321c60y9fy3grs3i89qak"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
@@ -57,8 +56,7 @@
'((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '())
- #t)))
+ '()))))
(add-before 'check 'adjust-test-infrastructure
(lambda _