summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-31 02:00:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-31 02:00:00 +0200
commitfe47ae3b7924c7e03fd23461e0bb334fe4a88861 (patch)
tree63da6ee5cf6b8c15615930567d0e4b03a06fe2c2 /gnu/packages/games.scm
parent32ac3efa98187a869fe47f84531ae4fe95dc9c0e (diff)
downloadguix-patches-fe47ae3b7924c7e03fd23461e0bb334fe4a88861.tar
guix-patches-fe47ae3b7924c7e03fd23461e0bb334fe4a88861.tar.gz
gnu: frotz: Update to 2.54.
This fixes the build. * gnu/packages/games.scm (frotz): Update to 2.54. [arguments]: Use G-expressions. Set CC in #:make-flags. Remove obsolete 'curses phase. Don't explicitly return #t from phases. [native-inputs]: Add pkg-config and which. [inputs]: Add ao.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06084d1167..d90e85de9e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8003,7 +8003,7 @@ open-source FPS of its kind.")
(define-public frotz
(package
(name "frotz")
- (version "2.44")
+ (version "2.54")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -8014,28 +8014,25 @@ open-source FPS of its kind.")
"frotz/frotz-" version ".tar.gz")))
(sha256
(base32
- "1v735xr3blznac8fnwa27s1vhllx4jpz7kw7qdw1bsfj6kq21v3k"))))
+ "1vsfq9ryyb4nvzxpnnn40k423k9pdy8k67i8390qz5h0vmxw0fds"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; there are no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'curses
- (lambda _
- (substitute* "Makefile"
- (("lcurses") "lncurses"))
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man (string-append out "/share/man/man6")))
- (install-file "frotz" bin)
- (mkdir-p man)
- (install-file "doc/frotz.6" man)
- #t))))))
- (inputs (list libmodplug libsamplerate libsndfile libvorbis ncurses))
+ (list #:tests? #f ; there are no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure-script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man6")))
+ (install-file "frotz" bin)
+ (mkdir-p man)
+ (install-file "doc/frotz.6" man)))))))
+ (native-inputs (list pkg-config which))
+ (inputs (list ao libmodplug libsamplerate libsndfile libvorbis ncurses))
(synopsis "Portable Z-machine interpreter (ncurses version) for text adventure games")
(description "Frotz is an interpreter for Infocom games and other Z-machine
games in the text adventure/interactive fiction genre. This version of Frotz