summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 19:09:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commitf114a689e70103dd7d00015663193d0b5f82f52e (patch)
tree83cecdb3700ab99fb8a2b8c5ce4f486e0d06854d /gnu/packages/games.scm
parentf2f0ef92f70ce9dbe008894105377c71a863f1ff (diff)
downloadguix-patches-f114a689e70103dd7d00015663193d0b5f82f52e.tar
guix-patches-f114a689e70103dd7d00015663193d0b5f82f52e.tar.gz
gnu: Add kollision.
* gnu/packages/games.scm (kollision): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a15f357e8a..01834c1581 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9281,3 +9281,42 @@ course more and more difficult the longer the snakes grow.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kollision
+ (package
+ (name "kollision")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kollision-" version ".tar.xz"))
+ (sha256
+ (base32 "1p7qrn3d0ybpvc9k6k5wzj54dsrp1rqh39844maz0ay2fhvmch12"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Simple ball dodging game")
+ (description "In Kollision you use mouse to control a small blue ball in a
+closed space environment filled with small red balls, which move about
+chaotically. Your goal is to avoid touching any of those red balls with your
+blue one, because the moment you do the game will be over. The longer you can
+stay in game the higher will your score be.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))