summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 21:23:42 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:44 +0100
commitd980ddb882b73cb76b722e41004a762e344c05f4 (patch)
treef4723b9758209050bdf6e3f9fd8e9abf70de0bd5 /gnu/packages/games.scm
parent72b69fa9ae60c0a574e1c891bb37d37341640048 (diff)
downloadguix-patches-d980ddb882b73cb76b722e41004a762e344c05f4.tar
guix-patches-d980ddb882b73cb76b722e41004a762e344c05f4.tar.gz
gnu: Add kbounce.
* gnu/packages/games.scm (kbounce): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 30d482ee69..512048daf9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8326,3 +8326,43 @@ or by puny earthlings.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kbounce
+ (package
+ (name "kbounce")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/"
+ version "/src/kbounce-" version ".tar.xz"))
+ (sha256
+ (base32 "02rfv0qzz5cmyfx8f56a45hbm9gsp6m3dcy8ajwx88rw5wpbrr11"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Jezzball arcade game")
+ (description "KBounce is a single player arcade game with the elements of
+puzzle. It is played on a field, surrounded by wall, with two or more balls
+bouncing around within the walls. The object of the game is to build new
+walls to decrease the size of the active field.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))