summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-21 15:31:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-21 22:41:44 +0100
commitd9580a26c7ad9638fee4282c24db8f48ec8f6fec (patch)
tree065ac8df56150cddc28f6451a03ad32577ea403f /gnu/packages/games.scm
parent813fa6e2c91f3d9ad3a83fcc0e99a19488898618 (diff)
downloadguix-patches-d9580a26c7ad9638fee4282c24db8f48ec8f6fec.tar
guix-patches-d9580a26c7ad9638fee4282c24db8f48ec8f6fec.tar.gz
gnu: jsoncpp: Update to 1.9.2.
* gnu/packages/serialization.scm (jsoncpp): Update to 1.9.2. * gnu/packages/games.scm (minetest)[source](snippet): Add substitution.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a072564d46..3d825cbe61 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1890,7 +1890,15 @@ match, cannon keep, and grave-itation pit.")
(modules '((guix build utils)))
(snippet
'(begin
- (delete-file-recursively "lib") #t))))
+ ;; Mimic upstream commit 706b6aad06, for compatibility with
+ ;; newer jsoncpp. Remove this for > 5.1.0.
+ (substitute* "cmake/Modules/FindJson.cmake"
+ (("features\\.h")
+ "allocator.h"))
+
+ ;; Delete bundled libraries.
+ (delete-file-recursively "lib")
+ #t))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags