summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-11-07 20:11:29 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-07 22:13:37 +0100
commitc9b991985814b58542e41e375d5fb5d009f55bfc (patch)
tree132c76bb2256caf28d77282d88e992ba7be77290 /gnu/packages/games.scm
parent574f4b7d3f8cf934d747dc15a6766c7f764404c7 (diff)
downloadguix-patches-c9b991985814b58542e41e375d5fb5d009f55bfc.tar
guix-patches-c9b991985814b58542e41e375d5fb5d009f55bfc.tar.gz
gnu: openttd-openmsx: Update to 0.4.2.
* packages/games.scm (openttd-openmsx): Update to 0.4.2. [native-inputs]: Replace python-2 with python-wrapper. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4764021f73..0b4f8c6bfe 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
(define openttd-openmsx
(package
(name "openttd-openmsx")
- (version "0.4.0")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
@@ -4442,11 +4442,13 @@ the original Transport Tycoon Deluxe.")
version "/openmsx-" version "-source.tar.xz"))
(sha256
(base32
- "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
+ "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
(build-system gnu-build-system)
(native-inputs
`(("grfcodec" ,grfcodec)
- ("python" ,python-2)
+ ; Scripts are Python3 compatible, but call the interpreter as
+ ; python instead of python3.
+ ("python" ,python-wrapper)
("tar" ,tar)))
(arguments
`(#:make-flags