summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTrevor Hass <thass@okstate.edu>2021-04-13 22:05:08 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-14 09:41:57 +0200
commitc5e149a9d9cf25c68da817f46ea0cbf5442d39bd (patch)
tree2cb2082148bfec8e42fffe35f8b630be0a47d9a6 /gnu/packages/games.scm
parenta758a8a3c20052c5f1228e1ec80068652bbc3849 (diff)
downloadguix-patches-c5e149a9d9cf25c68da817f46ea0cbf5442d39bd.tar
guix-patches-c5e149a9d9cf25c68da817f46ea0cbf5442d39bd.tar.gz
gnu: minetest: Fix absolute path to 'rm' command.
* gnu/packages/games.scm (minetest)[patch-sources]: Substitute '/bin/rm' path. [inputs]: Add coreutils. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dbc72446b2..91ac839aee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,7 +52,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
+;;; Copyright © 2020, 2021 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2020, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Lu hux <luhux@outlook.com>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
@@ -3486,8 +3486,13 @@ match, cannon keep, and grave-itation pit.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-sources
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/filesys.cpp"
+ ;; Use store-path for "rm" instead of non-existing FHS path.
+ (("\"/bin/rm\"")
+ (string-append "\"" (assoc-ref inputs "coreutils") "/bin/rm\"")))
(substitute* "src/CMakeLists.txt"
+ ;; Let minetest binary remain in build directory.
(("set\\(EXECUTABLE_OUTPUT_PATH .*\\)") ""))
(substitute* "src/unittest/test_servermodmanager.cpp"
;; do no override MINETEST_SUBGAME_PATH
@@ -3511,7 +3516,8 @@ match, cannon keep, and grave-itation pit.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("curl" ,curl)
+ `(("coreutils" ,coreutils)
+ ("curl" ,curl)
("freetype" ,freetype)
("gettext" ,gettext-minimal)
("gmp" ,gmp)