summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-31 12:47:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 14:49:47 +0200
commitbc5155b952ae8bdbc56aded4d8d39768b4e2a7d4 (patch)
tree6b55475d86c522543384dea7d1ab66bba32af63e /gnu/packages/games.scm
parentdac8d013bd1fc7f57b8ba3582eef6e0e01b23dfd (diff)
parent4e5000114ec01b5e92a87c52f2a10f9ba7a601c8 (diff)
downloadguix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar
guix-patches-bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c913d99334..34051b8fda 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4136,7 +4136,7 @@ falling, themeable graphics and sounds, and replays.")
(define-public wesnoth
(package
(name "wesnoth")
- (version "1.14.17")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/wesnoth/wesnoth-"
@@ -4145,7 +4145,7 @@ falling, themeable graphics and sounds, and replays.")
"wesnoth-" version ".tar.bz2"))
(sha256
(base32
- "1qc4ylhc4ab51milclzhflpmzw6bg35knwqaj3b157700jkcniin"))))
+ "0qs102ws46z0cqyk3maxd1c4bywswlacbqkpmb51x9jd8c746vhz"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no check target
@@ -6397,18 +6397,17 @@ with the mouse isn’t always trivial.")
(define-public chroma
(package
(name "chroma")
- (version "1.18")
+ (version "1.19")
(source (origin
(method url-fetch)
(uri (string-append "http://level7.org.uk/chroma/download/chroma-"
version ".tar.bz2"))
(sha256
(base32
- "12bjisf5nlqinw8n4r223vld52p0p2mw3fca92vi175c46bycbzn"))))
+ "19ybvv0dkql913xpgjgxyyy50s72vajc7hm83zsvy2lsq8lhg76q"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests included
- #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines
+ `(#:tests? #f)) ; no tests included
(inputs
`(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
("freetype" ,freetype)