summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 19:32:50 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:47 +0100
commita605b25b33e1acd95e8dd0ad197450dca43d4ad8 (patch)
tree5e992f5b1bed7f36eb475f57d7d90b1185c5ec22 /gnu/packages/games.scm
parent4e75911011b2715d9ea1d4750ec989d483abfd4b (diff)
downloadguix-patches-a605b25b33e1acd95e8dd0ad197450dca43d4ad8.tar
guix-patches-a605b25b33e1acd95e8dd0ad197450dca43d4ad8.tar.gz
gnu: Add kreversi.
* gnu/packages/games.scm (kreversi): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b06738f575..ee362acdfb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9362,3 +9362,47 @@ to destroy all ships wins the game.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kreversi
+ (package
+ (name "kreversi")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+"/src/kreversi-" version ".tar.xz"))
+ (sha256
+ (base32 "0b6q8df2bawgnrswhq59z37axad0q3zpvvzxdds7sz1lw505xw9h"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdeclarative" ,kdeclarative)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Old reversi board game, also known as othello")
+ (description "KReversi is a simple one player strategy game played
+against the computer.
+
+If a player's piece is captured by an opposing player, that piece is turned
+over to reveal the color of that player. A winner is declared when one player
+has more pieces of his own color on the board and there are no more possible
+moves.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))