summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 03:06:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 05:39:00 +0100
commit99e4e234110f4d206102d3d3a4b0ffb10cb85b15 (patch)
treeb3cda2daa5cef963023c195773f8372c650bdbda /gnu/packages/games.scm
parent106aac634dfd3f3d0f95b840fd5f7b63e51a5511 (diff)
downloadguix-patches-99e4e234110f4d206102d3d3a4b0ffb10cb85b15.tar
guix-patches-99e4e234110f4d206102d3d3a4b0ffb10cb85b15.tar.gz
gnu: fortune-mod: Update to 3.12.0.
* gnu/packages/games.scm (fortune-mod): Update to 3.12.0. [arguments]: Adjust 'delete-failing-test phase accordingly. [native-inputs]: Add docbook-xml-5, docbook-xsl, and perl-app-xml-docbook-builder.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 51c8133c2d..5896fa4333 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7567,7 +7567,7 @@ original.")
(define-public fortune-mod
(package
(name "fortune-mod")
- (version "2.28.0")
+ (version "3.12.0")
(source
(origin
(method git-fetch)
@@ -7576,7 +7576,7 @@ original.")
(commit (string-append "fortune-mod-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ppzgnffgdcmq6fq4gmdq2ig10ip2bnfgklkb3i8nc6bdxm7pb89"))))
+ (base32 "1iq3bxrw8758jqvfqaasd7w1zm0g28g9n25qccnzvr98997h6r2n"))))
(build-system cmake-build-system)
(arguments
(list #:test-target "check"
@@ -7585,6 +7585,11 @@ original.")
(add-after 'unpack 'enter-build-directory
(lambda _
(chdir "fortune-mod")))
+ (add-after 'enter-build-directory 'symlink-rinutils
+ (lambda _
+ (mkdir-p "rinutils")
+ (symlink #$(this-package-native-input "rinutils")
+ "rinutils/rinutils")))
(add-after 'enter-build-directory 'copy-cmake-modules
(lambda _
(copy-file #$shlomif-cmake-modules
@@ -7593,14 +7598,16 @@ original.")
#$shlomif-cmake-modules)))))
(add-after 'enter-build-directory 'delete-failing-test
(lambda _
- ;; TODO: Valgrind tests fail for some reason.
- ;; Similar issue: https://github.com/shlomif/fortune-mod/issues/21 (?)
- (delete-file "tests/t/valgrind.t")))
+ ;; TODO: Valgrind tests fail for some reason. Similar issue?
+ ;; https://github.com/shlomif/fortune-mod/issues/21
+ (delete-file "tests/data/valgrind.t")
+ (with-output-to-file "tests/scripts/split-valgrind.pl"
+ (const #t))))
(add-after 'install 'fix-install-directory
(lambda* (#:key outputs #:allow-other-keys)
- ;; Move binary from "games/" to "bin/" and remove the latter. This
- ;; is easier than patching CMakeLists.txt since the tests hard-code
- ;; the location as well.
+ ;; Move binary from "games/" to "bin/" and remove the
+ ;; latter. This is easier than patching CMakeLists.txt
+ ;; since the tests hard-code the location as well.
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(games (string-append out "/games")))
@@ -7610,6 +7617,10 @@ original.")
(inputs (list recode))
(native-inputs
(list perl
+ ;; For generating the documentation.
+ docbook-xml-5
+ docbook-xsl
+ perl-app-xml-docbook-builder
;; The following are only needed for tests.
perl-file-find-object
perl-test-differences