summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-02-23 20:31:32 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-02-23 20:31:32 -0500
commit98f790405c326cde29000e3834a0001ea4dd6d0e (patch)
tree4dfbd3d7cc6cfcc33be8524b3fc9bddd5bc735b1 /gnu/packages/games.scm
parent08fee94d0fd96ea2b40f9fec80dc3fa19e283019 (diff)
downloadguix-patches-98f790405c326cde29000e3834a0001ea4dd6d0e.tar
guix-patches-98f790405c326cde29000e3834a0001ea4dd6d0e.tar.gz
gnu: roguebox-adventures: Update to 3.0.1.
* gnu/packages/games.scm (roguebox-adventures): Update to 3.0.1. [arguments]: Adjust 'build' phase accordingly.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2e393dac61..d46253cda1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1388,7 +1388,7 @@ utilizing the art assets from the @code{SuperTux} project.")
(define-public roguebox-adventures
(package
(name "roguebox-adventures")
- (version "2.2.1")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
@@ -1398,7 +1398,7 @@ utilizing the art assets from the @code{SuperTux} project.")
(file-name (string-append name "-" version ".zip"))
(sha256
(base32
- "0kmzdgnik8fsf3bg55546l77p3mfxn2awkzfzzdn20n82rd2babw"))))
+ "05zd03s5w9kcpklfgcggbaa6rwf59nm0q9vcj6gh9v2lh402k067"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -1424,6 +1424,9 @@ utilizing the art assets from the @code{SuperTux} project.")
(string-append "'" data "'"))
(("^basic_path.*$")
(string-append "basic_path ='" data "'\n")))
+ (substitute* "LIB/dialog.py"
+ (("d_path = os\\.path\\.dirname\\(.*\\)\\)")
+ (string-append "d_path = '" data "'")))
(substitute* "LIB/gra_files.py"
(("basic_path = b_path\\.replace\\('/LIB',''\\)")
(string-append "basic_path ='" data "'\n")))