summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2021-01-13 18:28:40 -0500
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2021-01-13 18:30:41 -0500
commit872aa117d29896757a7075128059bb2dcb5b2ab3 (patch)
tree272139b00f50f1417aa82543abd8557ab2d7efd3 /gnu/packages/games.scm
parent23862011c3d02814181399765a024c7fa3fadd97 (diff)
downloadguix-patches-872aa117d29896757a7075128059bb2dcb5b2ab3.tar
guix-patches-872aa117d29896757a7075128059bb2dcb5b2ab3.tar.gz
gnu: crawl: Update to 0.26.0.
* gnu/packages/games.scm (crawl): Update to 0.26.0. Remove no-longer-needed snippet.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c5d2ff6048..b8f93505b3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6196,31 +6196,15 @@ fish. The whole game is accompanied by quiet, comforting music.")
(define-public crawl
(package
(name "crawl")
- (version "0.25.0")
+ (version "0.26.0")
(source
(origin
(method url-fetch)
- (uri (list
- ;; Older releases get moved into a versioned directory
- (string-append "http://crawl.develz.org/release/"
- (version-major+minor version) "/stone_soup-"
- version "-nodeps.tar.xz")
- ;; Only the latest release is in this directory
- (string-append "http://crawl.develz.org/release/stone_soup-"
- version "-nodeps.tar.xz")))
+ (uri (string-append "https://github.com/crawl/crawl/releases/download/"
+ version "/stone_soup-" version "-nodeps.tar.xz"))
(sha256
- (base32 "0rn1wjxdqw33caiwisfypm1j8cid3c9pz01ahicl17144zs29z3d"))
- (patches (search-patches "crawl-upgrade-saves.patch"))
- ;; The 0.25.0 -nodeps.tar.xz was built from an OSX machine; normally
- ;; apparently it's built from a Debian machine before the Debian
- ;; packages are made. These ._* files are binary and have the string
- ;; "Mac OS X" in them... removing these seems to result in compilation
- ;; again.
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file (find-files "." "^\\._"))
- #t))))
+ (base32 "1m81x1sp6p2ka5w2nib3pcw5w5iv58z41c8aqn0dayi1lb3yslfb"))
+ (patches (search-patches "crawl-upgrade-saves.patch"))))
(build-system gnu-build-system)
(inputs
`(("lua51" ,lua-5.1)