summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-02-05 00:31:17 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-05 17:36:08 +0100
commit838347207cdd96de1ad0127aaf4b2c378c7c2148 (patch)
treee0b1459999ef1b07b7fb07bb2e76984b1f3fd3a1 /gnu/packages/games.scm
parent4a42ef00152064aee86d3d4b3ea0c650009f610b (diff)
downloadguix-patches-838347207cdd96de1ad0127aaf4b2c378c7c2148.tar
guix-patches-838347207cdd96de1ad0127aaf4b2c378c7c2148.tar.gz
gnu: Add cockatrice.
* gnu/packages/games.scm (cockatrice): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 24c815d7ad..454742643e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -53,7 +53,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
-;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2020, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Lu hux <luhux@outlook.com>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
@@ -858,6 +858,52 @@ things far stranger and deadlier, and against the others like yourself, that
want what you have.")
(license license:cc-by-sa3.0)))
+(define-public cockatrice
+ (let ((release-date "2021-01-26"))
+ (package
+ (name "cockatrice")
+ (version "2.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cockatrice/Cockatrice")
+ (commit (string-append release-date "-Release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q8ffcklb2b7hcqhy3d2f9kz9aw22pp04pc9y4sslyqmf17pwnz9"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Strip image URLs as they point towards non-free web services
+ '(substitute* "cockatrice/src/settings/downloadsettings.cpp"
+ (("downloadURLs.append\\(\".*\"\\);") "")))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DWITH_SERVER=1"
+ "-DWITH_CLIENT=1"
+ "-DWITH_ORACLE=1"
+ "-DTEST=1")))
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("protobuf" ,protobuf)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
+ ("qtwebsockets" ,qtwebsockets)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (home-page "https://cockatrice.github.io")
+ (synopsis "Tabletop card game simulator")
+ (description "Cockatrice is a program for playing tabletop card games
+over a network. Its server design prevents users from manipulating the game
+for unfair advantage. The client also provides a single-player mode, which
+allows users to brew while offline.")
+ (license license:gpl2))))
+
(define-public corsix-th
(package
(name "corsix-th")