summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-06-16 09:06:20 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-06-16 15:04:49 -0400
commit7fc273fe3f555efd9723726f989ce015c0012ef7 (patch)
tree935359cdbf29437b76e8ae7789d4c254fab8eea4 /gnu/packages/games.scm
parent7146c8c75d5b389d648bfada1e1a59c302036dd5 (diff)
downloadguix-patches-7fc273fe3f555efd9723726f989ce015c0012ef7.tar
guix-patches-7fc273fe3f555efd9723726f989ce015c0012ef7.tar.gz
gnu: crawl: Update to 0.25.0.
* gnu/packages/games.scm (crawl): Update to 0.25.0.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10ac8cb550..e95effa992 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5264,7 +5264,7 @@ fish. The whole game is accompanied by quiet, comforting music.")
(define-public crawl
(package
(name "crawl")
- (version "0.24.0")
+ (version "0.25.0")
(source
(origin
(method url-fetch)
@@ -5277,8 +5277,18 @@ fish. The whole game is accompanied by quiet, comforting music.")
(string-append "http://crawl.develz.org/release/stone_soup-"
version "-nodeps.tar.xz")))
(sha256
- (base32 "0kdq6s12myxfdg75ma9x3ys2nd0xwb3xm2ynlmhg4628va0pnixr"))
- (patches (search-patches "crawl-upgrade-saves.patch"))))
+ (base32 "0rn1wjxdqw33caiwisfypm1j8cid3c9pz01ahicl17144zs29z3d"))
+ (patches (search-patches "crawl-upgrade-saves.patch"))
+ ;; The 0.25.0 -nodeps.tar.xz was built from an OSX machine; normally
+ ;; apparently it's built from a Debian machine before the Debian
+ ;; packages are made. These ._* files are binary and have the string
+ ;; "Mac OS X" in them... removing these seems to result in compilation
+ ;; again.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "." "^\\._"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("lua51" ,lua-5.1)