summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-13 20:31:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:02:51 +0100
commit5afffbeffc931d00074e570f5ec89df8a1ebe568 (patch)
tree148535f1e6127816f7675ae0db9b28d9ca3f726b /gnu/packages/games.scm
parente22c2c78a17b588edd994dc5b04659c06e45992a (diff)
downloadguix-patches-5afffbeffc931d00074e570f5ec89df8a1ebe568.tar
guix-patches-5afffbeffc931d00074e570f5ec89df8a1ebe568.tar.gz
gnu: fifengine: Fix build with newer Swig and Python.
* gnu/packages/patches/fifengine-swig-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/games.scm (fifengine)[source](patches): New field. [arguments]: Remove hard coded Python version from #:configure-flags.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e7764cc9ec..43199d2850 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2280,6 +2280,7 @@ Widgets, and allows users to create more.")
(uri (string-append "https://codeload.github.com/fifengine/"
"fifengine/tar.gz/" version))
(file-name (string-append name "-" version ".tar.gz"))
+ (patches (search-patches "fifengine-swig-compat.patch"))
(sha256
(base32
"1y4grw25cq5iqlg05rnbyxw1njl11ypidnlsm3qy4sm3xxdvb0p8"))))
@@ -2296,7 +2297,9 @@ Widgets, and allows users to create more.")
"/include/AL")
(string-append "-DPYTHON_SITE_PACKAGES="
(assoc-ref %outputs "out")
- "/lib/python3.7/site-packages"))
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-run_tests.py