summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-13 20:14:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:02:51 +0100
commit53402d437cbd6658377003058e827fa5a513eecf (patch)
tree11cd52960863ef558c73c792662e0962727f3eb4 /gnu/packages/games.scm
parent11a5ffba7327250ebe7b67c777204e49858310bb (diff)
downloadguix-patches-53402d437cbd6658377003058e827fa5a513eecf.tar
guix-patches-53402d437cbd6658377003058e827fa5a513eecf.tar.gz
gnu: wesnoth: Remove obsolete workaround.
* gnu/packages/games.scm (wesnoth)[arguments]: Remove #:phases.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 45d5c4697d..e7764cc9ec 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2665,20 +2665,7 @@ falling, themeable graphics and sounds, and replays.")
"1i8mz6gw3qar09bscczhki0g4scj8pl58v85rp0g55r4bcq41l5v"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no check target
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'treat-boost-as-system-header
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((boost (assoc-ref inputs "boost")))
- ;; Ensure Boost is treated as "system headers" to
- ;; pacify compiler warnings induced by Boost headers.
- (for-each (lambda (variable)
- (setenv variable
- (string-append boost "/include:"
- (or (getenv variable)
- ""))))
- '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"))
- #t))))))
+ `(#:tests? #f)) ;no check target
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))