summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorDan Frumin <dfrumin@cs.ru.nl>2019-07-27 20:18:22 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-24 00:37:37 +0100
commit46c5ae03cef60d78463edd2e5934ed90c1cebcd7 (patch)
treec66ff34e82a997d9b9879d0229266d156494de07 /gnu/packages/games.scm
parenta1fd8f01b2f599a538f193a218ebaea12c71302c (diff)
downloadguix-patches-46c5ae03cef60d78463edd2e5934ed90c1cebcd7.tar
guix-patches-46c5ae03cef60d78463edd2e5934ed90c1cebcd7.tar.gz
gnu: Add oshu.
* gnu/packages/games.scm (oshu): New variable. Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 99349eb66f..8c38f3aa98 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8414,6 +8414,45 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g598incc6zlls876slgwqblwiwiszkmqa4xpzw0z7mbjmmzsizz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ ;; `make test' doesn't actually build the test executable
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("ffmpeg" ,ffmpeg)
+ ("pango" ,pango)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Rhythm game in which you click on circles")
+ (description "@i{oshu!} is a minimalist variant of the @i{osu!} rhythm game,
+which is played by pressing buttons and following along sliders as they appear
+on screen. Its aim is to be able to play any beatmap even on low-end hardware.
+
+This package provides the core application, but no beatmaps. You need to
+download and unpack them separately.")
+ (license license:gpl3+)))
+
(define-public btanks
(package
(name "btanks")