summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-05-10 19:54:12 -0400
committerKei Kebreau <kkebreau@posteo.net>2021-05-26 15:10:52 -0400
commit2a8417d3b2c0256ba0bbb83b4fdfe3cac2f5dbe2 (patch)
treec1454f34ca9e565bc06965532917c70a6b3024a8 /gnu/packages/games.scm
parent88c442b4afd7a714397561fa98dd0b49ce18f8d5 (diff)
downloadguix-patches-2a8417d3b2c0256ba0bbb83b4fdfe3cac2f5dbe2.tar
guix-patches-2a8417d3b2c0256ba0bbb83b4fdfe3cac2f5dbe2.tar.gz
gnu: warzone2100: Update to 4.0.1.
* gnu/packages/games.scm (warzone2100): Update to 4.0.1. [arguments]: Disable vulkan backend with "-DWZ_ENABLE_BACKEND_VULKAN=off" configure flag. [inputs]: Add sqlite.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c7e6097bd4..9753f5af47 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5127,7 +5127,7 @@ in-window at 640x480 resolution or fullscreen.")
(define-public warzone2100
(package
(name "warzone2100")
- (version "3.4.1")
+ (version "4.0.1")
(source
(origin
(method url-fetch)
@@ -5135,7 +5135,7 @@ in-window at 640x480 resolution or fullscreen.")
version
"/warzone2100_src.tar.xz"))
(sha256
- (base32 "0savalmw1kp1sf8vg5aqrl5hc77p4jacxy5y9qj8k2hi2vqdfb7a"))
+ (base32 "1f8a4kflslsjl8jrryhwg034h1yc9y3y1zmllgww3fqkz3aj4xik"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5149,6 +5149,7 @@ in-window at 640x480 resolution or fullscreen.")
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DWZ_DISTRIBUTOR=Guix"
+ "-DWZ_ENABLE_BACKEND_VULKAN=off"
"-DENABLE_DISCORD=off")
#:tests? #f ; TODO: Tests seem to be broken, configure.ac is missing.
#:phases
@@ -5194,6 +5195,7 @@ in-window at 640x480 resolution or fullscreen.")
("qtscript" ,qtscript)
("openssl" ,openssl)
("sdl2" ,sdl2)
+ ("sqlite" ,sqlite)
("utfcpp" ,utfcpp)))
(home-page "https://wz2100.net")
(synopsis "3D Real-time strategy and real-time tactics game")