summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 19:21:32 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:43 +0100
commit2582f5827113bb463e9be65826bf689b38e47039 (patch)
tree099ad09ba3e4f5f985cbb92b09341f002ceda3c9 /gnu/packages/games.scm
parente1b174eb4b7ed1ab960609d53e9cd4bd845b6d13 (diff)
downloadguix-patches-2582f5827113bb463e9be65826bf689b38e47039.tar
guix-patches-2582f5827113bb463e9be65826bf689b38e47039.tar.gz
gnu: Add libkmahjongg.
* gnu/packages/kde-misc.scm (libkmahjongg): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 401fb8c790..22eb0ffb4d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8050,3 +8050,34 @@ Features are:
This package is part of the KDE games module.")
(license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+(define-public libkmahjongg
+ (package
+ (name "libkmahjongg")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/"
+ version "/src/libkmahjongg-" version ".tar.xz"))
+ (sha256
+ (base32 "0rdimk11hrc8qrmiv26z0ddjzi1k6806c0rfskx4cwmildmh6zgx"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kcompletion" ,kcompletion)
+ ;("kconfig" ,kconfig)
+ ("kcodecs" ,kcodecs)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Shared library for kmahjongg and kshisen")
+ (description "Shared library and common files for kmahjongg, kshisen and
+other Mah Jongg like games.")
+ (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))