summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-05-03 23:56:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-04 00:59:40 +0200
commit1d5560494bc1d64d591288072c664ce7ab548202 (patch)
treeeccd15ff7c05334cab570228b3d2aa84ff630bbb /gnu/packages/games.scm
parentcc7c1f904e59e4c6d8dde0f7be353b0042e5277b (diff)
downloadguix-patches-1d5560494bc1d64d591288072c664ce7ab548202.tar
guix-patches-1d5560494bc1d64d591288072c664ce7ab548202.tar.gz
gnu: chess: Fix paths in installed shell scripts.
* gnu/packages/games.scm (chess)[arguments]: Add a 'fix-shell-scripts phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 073e41eec6..9d7c8ef341 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3163,6 +3163,16 @@ asynchronously and at a user-defined speed.")
(base32
"0ilq4bfl0lwyzf11q7n2skydjhalfn3bgxhrp5hjxs5bc5d6fdp5"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'fix-shell-scripts
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (chdir bin)
+ (substitute* '("gnuchessx" "gnuchessu")
+ (("^gnuchess") (string-append bin "/gnuchess")))))))))
(home-page "https://www.gnu.org/software/chess/")
(synopsis "Full chess implementation")
(description "GNU Chess is a chess engine. It allows you to compete