summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-14 15:53:57 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-14 22:44:15 +0200
commit1b917f99b5fb2968a381ef0acd43db7f711f2db9 (patch)
tree3a4f4dccc6ee493e4a82d4aae464b50b7dc8e817 /gnu/packages/games.scm
parent526a0066ac243f9b740cd2df9e6bb56bcd51e378 (diff)
downloadguix-patches-1b917f99b5fb2968a381ef0acd43db7f711f2db9.tar
guix-patches-1b917f99b5fb2968a381ef0acd43db7f711f2db9.tar.gz
gnu: Add augustus.
* gnu/packages/games.scm (augustus): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 32d7d8d478..10ac8cb550 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1011,6 +1011,45 @@ does not include game data.")
(license (list license:agpl3
license:zlib)))) ; ext/tinyfiledialogs
+(define-public augustus
+ (package
+ (inherit julius)
+ (name "augustus")
+ (version (package-version julius))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Keriew/augustus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ii0w0iwa9zv5bbqfcps5mxifd796m6fw4gvjf09pkm3yjgqc0ag"))
+ ;; Remove unused bundled libraries.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (with-directory-excursion "ext"
+ (for-each delete-file-recursively '("dirent" "png" "SDL2" "zlib")))
+ #t))))
+ (arguments
+ ;; No tests. See https://github.com/Keriew/augustus/issues/82.
+ `(#:tests? #f))
+ (home-page "https://github.com/Keriew/augustus")
+ (synopsis "Re-implementation of Caesar III game engine with gameplay changes")
+ (description
+ "Fork of Julius, an engine for the a city-building real-time strategy
+game Caesar III. Gameplay enhancements include:
+
+@itemize
+@item roadblocks;
+@item market special orders;
+@item global labour pool;
+@item partial warehouse storage;
+@item increased game limits;
+@item zoom controls.
+@end itemize\n")))
+
(define-public meandmyshadow
(package
(name "meandmyshadow")