summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-28 11:26:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-28 11:26:16 +0100
commit1a3233f074ddd9a607860256b0ec582b0717ec69 (patch)
tree29e1eadcb4a30ea53e6932cf11bf28527f535fa9 /gnu/packages/games.scm
parent295016183caa4943522125528b81ad8c67787ca1 (diff)
downloadguix-patches-1a3233f074ddd9a607860256b0ec582b0717ec69.tar
guix-patches-1a3233f074ddd9a607860256b0ec582b0717ec69.tar.gz
gnu: yamagi-quake2: Update to 7.45.
* gnu/packages/games.scm (yamagi-quake2): Update to 7.45. [inputs]: Add curl-minimal. Sort alphabetically.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 038379ae62..62f62ae263 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6817,15 +6817,14 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(define-public yamagi-quake2
(package
(name "yamagi-quake2")
- (version "7.10")
+ (version "7.45")
(source
(origin
(method url-fetch)
(uri (string-append "https://deponie.yamagi.org/quake2/quake2-"
version ".tar.xz"))
(sha256
- (base32
- "0psinbg25mysd58k99s1n34w31w5hj1vppb39gdjb0zqi6sl6cps"))))
+ (base32 "0rgz8x7lzd0zb0xqd0gvnf2641nr9xpfm6v14mgh99hspxklaln7"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
@@ -6854,12 +6853,15 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(string-append out "/bin/yamagi-quake2"))
(symlink (string-append out "/lib/yamagi-quake2/q2ded")
(string-append out "/bin/yamagi-q2ded"))))))))
- (inputs `(("sdl2" ,sdl2)
- ("mesa" ,mesa)
- ("libvorbis" ,libvorbis)
- ("zlib" ,zlib)
- ("openal" ,openal)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl-minimal)
+ ("libvorbis" ,libvorbis)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
(synopsis "First person shooter engine based on quake2")
(description "Yamagi Quake II is an enhanced client for id Software's Quake II.
The main focus is an unchanged single player experience like back in 1997,