summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-04 00:22:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-04 00:22:09 +0100
commit13a7336594a213690a64bbe891ddb47b81592e36 (patch)
tree90a1d81bc7a2874e287d4695a50f46ffa2c0b65e /gnu/packages/games.scm
parent92faad0adb93b8349bfd7c67911d3d95f0505eb2 (diff)
downloadguix-patches-13a7336594a213690a64bbe891ddb47b81592e36.tar
guix-patches-13a7336594a213690a64bbe891ddb47b81592e36.tar.gz
gnu: naev: Update to 0.9.1.
* gnu/packages/games.scm (naev): Update to 0.9.1. [source]: Use URL-FETCH. [arguments]<#:phases>: Remove keyword. [native-inputs]: Remove NAEV-ARTWORK. (naev-artwork): Remove variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm57
1 files changed, 8 insertions, 49 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f086252dba..632f040369 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2017, 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2017–2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2018 Madalin Ionel-Patrascu <madalinionel.patrascu@mdc-berlin.de>
@@ -7916,34 +7916,21 @@ ncurses for text display.")
(define-public naev
(package
(name "naev")
- (version "0.9.0")
+ (version "0.9.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/naev/naev")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/naev/naev/releases/download/v"
+ version "/naev-" version "-source.tar.xz"))
(sha256
- (base32 "0m4bny6wcxmqavi8sf87yjg4mamhyixzz4gb9m97xwkn6ga5669b"))))
+ (base32 "1v7ibl0xdr8a93c73mbbg1lnsc1a67nsg1waqb8fsdw6yrs39508"))))
(build-system meson-build-system)
(arguments
;; XXX: Do not add debugging symbols, which cause the build to fail.
`(#:configure-flags (list "--buildtype=release")
- #:tests? #f ;sole test fails with a missing "/dev/dri" error
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'copy-artwork
- (lambda* (#:key inputs #:allow-other-keys)
- (copy-recursively (assoc-ref inputs "naev-artwork")
- "artwork")))
- (add-before 'configure 'find-msgfmt
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "utils/build/gen_gettext_stats.py"
- (("msgfmt")
- (search-input-file inputs "/bin/msgfmt"))))))))
+ #:tests? #f)) ;sole test fails with a missing "/dev/dri" error
(native-inputs
- (list gettext-minimal naev-artwork pkg-config))
+ (list gettext-minimal pkg-config))
(inputs
(list freetype
glpk
@@ -7977,34 +7964,6 @@ of lore accompanying everything from planets to equipment.")
license:bsd-3 ;perlin.c
))))
-(define-public naev-artwork
- (let ((version "0.9.0")
- (commit "7f38a772ef2618f199ea68ecbd9f5c97e357fe36"))
- (package
- (name "naev-artwork")
- (version (git-version version "0" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/naev/naev-artwork-production")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1g3dk3372k6g7k9andkip0vk146kwy43x98xwzzqdry1pa5m56v0"))))
- (build-system copy-build-system)
- (home-page "https://naev.org/")
- (synopsis "Game about space exploration, trade and combat — data files")
- (description
- "This package contains graphics and sound files for Naev.")
- (license (list license:silofl1.1
- license:gpl2+
- license:cc0
- license:cc-by3.0
- license:cc-by-sa3.0
- license:cc-by4.0
- license:cc-by-sa4.0)))))
-
(define-public frotz-dumb-terminal
(package
(name "frotz-dumb-terminal")