summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-25 21:56:25 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-25 23:15:39 +0100
commit138498feec335f68935f00f8a97924c90c7f59b0 (patch)
tree1d2cf2be4b397f709276a1cd1b5bf3e90b8e9be7 /gnu/packages/games.scm
parentfa35a5f649518a5c3e41aec796ee9b6b852d93c0 (diff)
downloadguix-patches-138498feec335f68935f00f8a97924c90c7f59b0.tar
guix-patches-138498feec335f68935f00f8a97924c90c7f59b0.tar.gz
gnu: Use 'search-input-directory' for the SDL header directory.
This is a followup to bf182596a9d85604f6f029302671a38001575355. * gnu/packages/games.scm (prboom-plus, red-eclipse, btanks) (edgar): Use 'search-input-directory' instead of 'search-input-file' when looking for "include/SDL". (abbaye): Likewise, and search "include/SDL2" instead of "include/SDL".
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 99c4b0a7e2..cdd3452fd8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2195,7 +2195,7 @@ Every puzzle has a complete solution, although there may be more than one.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "/include/SDL")
+ (search-input-directory inputs "/include/SDL")
":" (or (getenv "CPATH") ""))))))))
(inputs
`(("fluidsynth" ,fluidsynth)
@@ -3037,7 +3037,7 @@ properly.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "include/SDL")
+ (search-input-directory inputs "include/SDL2")
":" (or (getenv "CPATH") "")))))
(add-after 'patch-source-shebangs 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)
@@ -4857,7 +4857,7 @@ http://lavachat.symlynx.com/unix/")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "/include/SDL2")
+ (search-input-directory inputs "/include/SDL2")
":" (or (getenv "CPATH") "")))))
(add-after 'install 'copy-data
(lambda* (#:key outputs #:allow-other-keys)
@@ -8642,7 +8642,7 @@ download and unpack them separately.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "/include/SDL")
+ (search-input-directory inputs "/include/SDL")
":" (or (getenv "CPATH") "")))))
(add-after 'unpack 'fix-compilation-errors
(lambda _
@@ -8910,7 +8910,7 @@ where the player draws runes in real time to effect the desired spell.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "/include/SDL2")
+ (search-input-directory inputs "/include/SDL2")
":" (or (getenv "CPATH") ""))))))))
(inputs
`(("sdl2-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))