summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-03-16 11:37:23 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:44 +0100
commit110b738be68f3eac77eec4ee7b8d5cad18d39bd5 (patch)
tree90ca318218f93c2d0b7cf9228eb993e780519fdf /gnu/packages/games.scm
parentc57e31fbc2d9ac1a828103f34c5a1ebf2fba1361 (diff)
downloadguix-patches-110b738be68f3eac77eec4ee7b8d5cad18d39bd5.tar
guix-patches-110b738be68f3eac77eec4ee7b8d5cad18d39bd5.tar.gz
gnu: Add kshisen.
* gnu/packages/games.scm (kshisen): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f44331ccb4..00de70dfbf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8122,3 +8122,43 @@ layouts.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
+(define-public kshisen
+ (package
+ (name "kshisen")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/"
+ version "/src/kshisen-" version ".tar.xz"))
+ (sha256
+ (base32 "1bq5m48af4h5apfp3bfsp76nlpv6h5sc0gd544zv7cgpfznz1sds"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ;("perl" ,perl)
+ ;("pkg-config" ,pkg-config)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kcompletion" ,kcompletion)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("libkmahjongg" ,libkmahjongg)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Shisen-Sho solitaire game")
+ (description "KShisen is a solitaire-like game played using the standard
+set of Mahjong tiles. Unlike Mahjong however, KShisen has only one layer of
+scrambled tiles
+
+This package is part of the KDE games module.")
+ (license license:gpl2+)))