summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 12:11:42 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 15:02:14 +0200
commit0b95f51eae50fbe627a354f50fa053a6d52b81aa (patch)
tree4fe3be8f51b6e7caab23d6af21b6fcb6a78897fb /gnu/packages/games.scm
parentdc6cd35e6d369f7591217065959234e5a23b008e (diff)
downloadguix-patches-0b95f51eae50fbe627a354f50fa053a6d52b81aa.tar
guix-patches-0b95f51eae50fbe627a354f50fa053a6d52b81aa.tar.gz
gnu: enigma: Fix build with GCC >= 6.
* gnu/packages/games.scm (enigma)[arguments]: Add phase to substitute faulty comparison.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 556f813396..213acc6b9f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5841,6 +5841,14 @@ The Flag. You can even design your own maps!")
(list "--with-system-enet")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-with-new-gcc
+ (lambda _
+ ;; Fix build with GCC6 and later by avoiding comparing ifstream
+ ;; to NULL. Can be removed for versions > 1.21.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "ifs"))
+ #t))
(add-after 'unpack 'find-sdl
(lambda _
(substitute* "configure"