summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 13:35:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 17:48:01 +0100
commit0b09364d5f00d2b8b2e341487c6a33ede76bfb9a (patch)
tree74f46e840c0029876244abc5df49303044dac77a /gnu/packages/games.scm
parent9d8ebe703e3a3caa2c6b4aaaf9a61b00b7bd0f5b (diff)
downloadguix-patches-0b09364d5f00d2b8b2e341487c6a33ede76bfb9a.tar
guix-patches-0b09364d5f00d2b8b2e341487c6a33ede76bfb9a.tar.gz
gnu: tome4: Prepare for cross-compilation.
* gnu/packages/games.scm (tome4)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7c36e67498..439e369fe4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6620,7 +6620,9 @@ Crowther & Woods, its original authors, in 1995. It has been known as
("vorbis" ,libvorbis)
("luajit" ,luajit)))
(arguments
- `(#:make-flags '("CC=gcc" "config=release")
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ "config=release")
;; XXX: Building in parallel occasionally causes this build failure:
;; ../src/luajit2/src/host/buildvm.c:73:10: fatal error: buildvm_arch.h:
;; No such file or directory