summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-28 17:12:29 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-28 17:12:29 +0100
commit0ae0efd9a3499bced46178d52db2d83d0123f34c (patch)
treecc464a5092dc71d4f22e7e740a4c0db652589a8c /gnu/packages/games.scm
parentc76d0201f7cc639f51dbf259779d86dad62417cd (diff)
downloadguix-patches-0ae0efd9a3499bced46178d52db2d83d0123f34c.tar
guix-patches-0ae0efd9a3499bced46178d52db2d83d0123f34c.tar.gz
gnu: nudoku: Update to 2.1.0.
* gnu/packages/games.scm (nudoku): Update to 2.1.0. [native-inputs]: Add autoconf, automake, gettext-minimal and pkg-config. [source]: Use git-fetch since the last tag is not released as an archive.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 62f62ae263..1b7faa97c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6879,17 +6879,23 @@ making Yamagi Quake II one of the most solid Quake II implementations available.
(define-public nudoku
(package
(name "nudoku")
- (version "1.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jubalh/nudoku/"
- "releases/download/" version
- "/nudoku-" version ".tar.xz"))
- (sha256
- (base32
- "0nr2j2z07nxk70s8xnmmpzccxicf7kn5mbwby2kg6aq8paarjm8k"))))
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jubalh/nudoku.git")
+ (commit version)))
+ (sha256
+ (base32 "12v00z3p0ymi8f3w4b4bgl4c76irawn3kmd147r0ap6s9ssx2q6m"))))
(build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ncurses" ,ncurses)))
(home-page "https://jubalh.github.io/nudoku/")
(synopsis "Sudoku for your terminal")
(description "Nudoku is a ncurses-based Sudoku game for your terminal.")