summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-07 23:36:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-07 23:55:51 +0200
commit096897889f54f1649c2c18f27d62f9f00207334e (patch)
tree740f7a0b5630e4afb0a53ab744839bd0922933d0 /gnu/packages/games.scm
parent1ccc5cfc387d14fa3ebe864e16c0637994819b0f (diff)
downloadguix-patches-096897889f54f1649c2c18f27d62f9f00207334e.tar
guix-patches-096897889f54f1649c2c18f27d62f9f00207334e.tar.gz
gnu: solarus: Update to 1.6.5.
* gnu/packages/games.scm (solarus): Update to 1.6.5. (solarus-quest-editor)[source]: Update hash. [arguments]: Remove obsolete 'fix-qt-build phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3f909aad4b..048784ab2c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2325,7 +2325,7 @@ and defeat them with your bubbles!")
(name "solarus")
;; XXX: When updating this package, please also update hash in
;; `solarus-quest-editor' below.
- (version "1.6.4")
+ (version "1.6.5")
(source
(origin
(method git-fetch)
@@ -2334,7 +2334,7 @@ and defeat them with your bubbles!")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n6l91yyqjx0pz4w1lp3yybpq0fs2yjswfcm8c1wjfkxwiznbdxi"))))
+ (base32 "0ny9dgqphjv2l39rff2621hnrzpf8qin8vmnv7jdz20azjk4m8id"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -2393,19 +2393,9 @@ in mind.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qbc2j9kalk7xqk9j27s7wnm5zawiyjs47xqkqphw683idmzmjzn"))))
+ (base32 "1pvjgd4faxii5sskw1h55lw90hlbazhwni8nxyywzrmkjbq7irm0"))))
(arguments
- `(#:tests? #false ;no test
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-qt-build
- ;; XXX: Fix build with Qt 5.15. It has been applied upstream as
- ;; 81d5c7f1 and can be removed at next upgrade.
- (lambda _
- (substitute* "src/entities/jumper.cpp"
- (("#include <QPainter>" all)
- (string-append all "\n" "#include <QPainterPath>\n")))
- #t)))))
+ `(#:tests? #false)) ; no test suite
(inputs
`(("solarus" ,solarus)
,@(package-inputs solarus)))