summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-24 16:07:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-24 16:34:28 +0200
commitf0e4cfcb0bdb09f95641b42e5133d2aab3e4f5f9 (patch)
treeabd3bc999772f2161c5cc91aad553728a62fb110 /gnu/packages/game-development.scm
parentedf1ce60f7b418c6552da71661f6aeea2aae85c2 (diff)
downloadguix-patches-f0e4cfcb0bdb09f95641b42e5133d2aab3e4f5f9.tar
guix-patches-f0e4cfcb0bdb09f95641b42e5133d2aab3e4f5f9.tar.gz
gnu: bennu-game-development: Build against openssl on all archictures.
* gnu/packages/game-development.scm (bennu-game-development)[arguments]: Rename custom phase to 'patch-configure-to-use-openssl, change glob pattern to match all cases. Return #t from all phases.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b57f46c69e..49fe467252 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1353,20 +1353,21 @@ that parenthetically inclined game developers need to make 2D (and eventually
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-configure-for-x86-64
+ (add-after 'unpack 'patch-configure-to-use-openssl
(lambda* (#:key outputs #:allow-other-keys)
(chdir "core")
(delete-file "configure")
(substitute* "configure.in"
(("i\\*86\\)")
- "x86_64)
+ "*)
COMMON_CFLAGS=\"$COMMON_CFLAGS -DUSE_OPENSSL\"
COMMON_LDFLAGS=\"$COMMON_LDFLAGS\"
LIBSSL=\"crypto\"
USE_OPENSSL=yes
;;
- i*86)")))))))
+ i*86)"))
+ #t)))))
(inputs `(("openssl" ,openssl)
("zlib" ,zlib)))
(native-inputs `(("pkg-config" ,pkg-config)