summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-07 20:09:25 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-07 20:14:50 +0200
commite877f4d012342cc5fa916652b3846e40fdcd0491 (patch)
tree38c2080cc1ed00e89e3df462962df377400deba7 /gnu/packages/game-development.scm
parent8ba31e8bd1f780301a429bbd826aa26daad9e71c (diff)
downloadguix-patches-e877f4d012342cc5fa916652b3846e40fdcd0491.tar
guix-patches-e877f4d012342cc5fa916652b3846e40fdcd0491.tar.gz
gnu: nml: Fix for newer pillow version.
* gnu/packages/game-development.scm (nml)[arguments]: Add a phase to fix for newer pillow.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7eac935a69..bb4c1d26bb 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -314,6 +314,16 @@ provide connectivity for client applications written in any language.")
(base32
"1pmvvm3sgnpngfa7884mqhq3fwdjh9sr0ca07ypnidcg0y341w53"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-pillow
+ (lambda _
+ ;; pillow's version is not in PIL.Image.VERSION anymore
+ (substitute* "nml/version_info.py"
+ (("from PIL import Image") "import PIL")
+ (("Image.VERSION") "PIL.__version__"))
+ #t)))))
(propagated-inputs
`(("python-pillow" ,python-pillow)
("python-ply" ,python-ply)))