summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-01 17:08:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-02 18:54:14 +0100
commitd6660ef6ee014d5e3a2e8d0dad0a4a4b800cebc7 (patch)
treee49755fe21e357620920d87eb8478ff33b1da6c2 /gnu/packages/game-development.scm
parent74d811297dccb23f585084b40724643d262101d6 (diff)
downloadguix-patches-d6660ef6ee014d5e3a2e8d0dad0a4a4b800cebc7.tar
guix-patches-d6660ef6ee014d5e3a2e8d0dad0a4a4b800cebc7.tar.gz
gnu: deutex: Update to 5.2.2.
* gnu/packages/game-development.scm (deutex): Update to 5.2.2. [source]: Change tarball extension. [native-inputs]: Add zstd.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 79bb6ec7e3..fa7875d077 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -163,21 +163,22 @@ is used in some video games and movies.")
(define-public deutex
(package
(name "deutex")
- (version "5.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/Doom-Utils/deutex"
- "/releases/download/v" version "/"
- "deutex-" version ".tar.xz"))
- (sha256
- (base32
- "07w3asqxx89wl2wfv1z3cak8v83h3ys3b39mq9qq4gyf3xdhs76n"))))
+ (version "5.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Doom-Utils/deutex"
+ "/releases/download/v" version "/"
+ "deutex-" version ".tar.zst"))
+ (sha256
+ (base32 "0psb2za6ldrlak7s8pjvli98ij5yiwjx8j1ms2v7rj9yadx0xv8h"))))
(build-system gnu-build-system)
(inputs
`(("libpng" ,libpng)))
(native-inputs
`(("asciidoc" ,asciidoc)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("zstd" ,zstd)))
(home-page "https://github.com/Doom-Utils/deutex")
(synopsis "WAD file composer for Doom and related games")
(description