summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-18 19:41:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-18 19:41:08 +0100
commitc4d769d359c67680fe55c3b71e659cd31837f3ec (patch)
tree928fe50be266c8975f4abad56e07ce4ebaef55fe /gnu/packages/game-development.scm
parentde2871c9faa44ee07f73470441f05d114a43bb48 (diff)
parent4de63cf3fc0a831d75cb507456821104f24800c2 (diff)
downloadguix-patches-c4d769d359c67680fe55c3b71e659cd31837f3ec.tar
guix-patches-c4d769d359c67680fe55c3b71e659cd31837f3ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm40
1 files changed, 38 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index e59a0f6424..00c0227749 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1536,7 +1536,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.2")
+ (version "3.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1545,7 +1545,7 @@ games.")
(file-name (git-file-name name version))
(sha256
(base32
- "0f15izjl4i2xlz1xj5pcslzl9gm3rmr3c21gh256ynpi2zhhkcdd"))
+ "1kndls0rklha7kz9l4i2ivjxab4jpk3b2j7dcgcg2qc3s81yd0r6"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -1774,6 +1774,42 @@ that parenthetically inclined game developers need to make 2D (and eventually
@end enumerate\n")
(license license:gpl3+)))
+(define-public guile3.0-chickadee
+ (package
+ (inherit guile-chickadee)
+ (name "guile-chickadee")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://files.dthompson.us/chickadee/"
+ "chickadee-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fdicsgls5cp0yffcm5vjmav67gv9bxhz1s3jvdvinspxb485x7l"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("guile-opengl" ,guile3.0-opengl)
+ ("guile-sdl2" ,guile3.0-sdl2)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (home-page "https://dthompson.us/projects/chickadee.html")
+ (synopsis "Game development toolkit for Guile Scheme with SDL2 and OpenGL")
+ (description "Chickadee is a game development toolkit for Guile Scheme
+built on top of SDL2 and OpenGL. Chickadee aims to provide all the features
+that parenthetically inclined game developers need to make 2D (and eventually
+3D) games in Scheme, such as:
+
+@enumerate
+@item extensible, fixed-timestep game loop
+@item OpenGL-based rendering engine
+@item keyboard, mouse, controller input
+@item REPL-driven development model
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public bennu-game-development
(package
(name "bennu-game-development")