summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-16 15:39:51 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:22 +0200
commitbf182596a9d85604f6f029302671a38001575355 (patch)
treeab99ec4b5db48abf76ea81d709f20c6486688567 /gnu/packages/game-development.scm
parent6ea7297ea49f6c704afb727a5afe7ef9ce4a4f73 (diff)
downloadguix-patches-bf182596a9d85604f6f029302671a38001575355.tar
guix-patches-bf182596a9d85604f6f029302671a38001575355.tar.gz
gnu: Use 'search-input-directory' for the SDL header directory.
* gnu/packages/education.scm (gcompris)[arguments]: Use 'search-input-directory' when searching for SDL headers. * gnu/packages/education.scm (t4k-common): Likewise. (tuxmath): Likewise. * gnu/packages/game-development.scm (tesseract-engine): Likewise. * gnu/packages/games.scm (foobillard++): Likewise. (ltris): Likewise. (prboom-plus): Likewise. (abbaye): Likewise. (red-eclipse): Likewise. (kiki): Likewise. (tome4): Likewise. (btanks): Likewise. (4dtris): Likewise. (edgar): Likewise. * gnu/packages/python-xyz.scm (python-kivy): Likewise.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index e24b7bbed9..32172b2db0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2599,10 +2599,9 @@ support.")
(add-before 'build 'fix-env
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl2-union")
- "/include/SDL2:"
- (or (getenv "CPATH") "")))
- #t))
+ (string-append
+ (search-input-directory inputs "include/SDL2")
+ ":" (or (getenv "CPATH") "")))))
(add-after 'install 'really-install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))