summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:34:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:41:20 +0100
commitb2cf559772499ca96f9a678e12a50b34305b4626 (patch)
tree97b4f74909d984efb40ce19c3836cc637460bb59 /gnu/packages/game-development.scm
parent7aed8b8a7aa7394bb2b682854998df7b86623c71 (diff)
downloadguix-patches-b2cf559772499ca96f9a678e12a50b34305b4626.tar
guix-patches-b2cf559772499ca96f9a678e12a50b34305b4626.tar.gz
gnu: allegro@4: Update to 4.4.3.
* gnu/packages/game-development.scm (allegro-4): Update to 4.4.3. [source]: Remove upstreamed patch. * gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6b641be0ef..c2732cac81 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -641,17 +641,15 @@ programming language.")
(define-public allegro-4
(package
(name "allegro")
- (version "4.4.2")
+ (version "4.4.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/liballeg/allegro5/"
"releases/download/" version "/allegro-"
version ".tar.gz"))
- (patches (search-patches
- "allegro4-mesa-18.2.5-and-later.patch"))
(sha256
(base32
- "1p0ghkmpc4kwij1z9rzxfv7adnpy4ayi0ifahlns1bdzgmbyf88v"))))
+ "1d5ws3ihvpa6f4qc6a6drq31pajw6bblxifr4kcxzqj9br1nw28y"))))
(build-system cmake-build-system)
(arguments
'(#:phases